go导七牛包出错Cannot find module github/qiniu/x/bytes

问题描述

 𝝺 go get -u github.com/qiniu/api.v7
go: finding github.com/qiniu/x v8.0.0+incompatible
go: finding golang.org/x/net latest
../../../../../pkg/mod/github.com/qiniu/api.v7@v7.2.5+incompatible/storage/resume_base.go:13:2: cannot find module providing package github.com/qiniu/x/bytes.v7
../../../../../pkg/mod/github.com/qiniu/api.v7@v7.2.5+incompatible/auth/qbox/qbox_auth.go:12:2: cannot find module providing package github.com/qiniu/x/bytes.v7/seekable
../../../../../pkg/mod/github.com/qiniu/api.v7@v7.2.5+incompatible/storage/rpc.go:13:2: cannot find module providing package github.com/qiniu/x/reqid.v7
../../../../../pkg/mod/github.com/qiniu/api.v7@v7.2.5+incompatible/storage/resume_base.go:14:2: cannot find module providing package github.com/qiniu/x/xlog.v7

解决方案

go.mod 添加

require (
    qiniupkg.com/x v7.0.8+incompatible // indirect
    github.com/qiniu/x v7.0.8+incompatible // indirect
)
bug 
更新时间:2020-08-11 21:01:16

本文由 智慧煮粥 创作,如果您觉得本文不错,请随意赞赏
采用 知识共享署名4.0 国际许可协议进行许可
本站文章除注明转载/出处外,均为本站原创或翻译,转载前请务必署名
原文链接:http://zz.zzhub.cn/archives/goqiniuerror
最后更新:2020-08-11 21:01:16

评论

Your browser is out of date!

Update your browser to view this website correctly. Update my browser now

×